Office 2013 – is it me ?

Old 1 Comment on Office 2013 – is it me ? 12

“Is it me?, am I doing something wrong? Back in the day you purchased Office, installed it from
floppies (yes I was that soldier) CDs etc, entered the Product key and all was well in the world.

Now – Office 2013 Home & Business 2013.

Create a Microsoft account and validate (Max of 3 accounts a day)
Register the Product key.
Run the installer
Activate Product – “Product Activated”

Then having been OK for 3 -4 months Office 2013 stops responding.

You Click on Word, Excel or Outlook, it has a little think and does nothing.

Performing an Online or Quick repair fixes the issue but something is seriously flawed with this software.

Anyone else had similar issues?

Author

John R

John Reidy is an IT Manager for a Transport & Logistics Group of Companies in the UK. John’s background is in Network support and design for the Ministry of Defence, commercial premises, Ports and Sea going vessels serving the European Ferry industry. A BICSI trained and qualified Technician and promoter of the methodology for optimised best of breed information transport systems he designs LAN/WAN solutions together with hosted and on premise Telephony PBX solutions. John currently supports 190 users over 8 companies throughout the UK and Middle East supporting all aspects of the business associated technology and infrastructure on a 24/7 basis.

Related Articles

1 Comment

  1. Martin Lehner June 11, 2014 at 2:45 pm

    Hey John,

    I haven’t had any issues with this, and I’ve had Office 2013 deployed since……. let me think here, our oldest one is about a year in a production environment ?

    That said, I’m across the pond from you, so our authentication servers / methods might not be the same as you.

Leave a comment

Back to Top